Jan 092015
 

i was recently trying to install the event module for php, and ran into a weird error:

$ pecl install event
...
configure: error: bufferevent_openssl_get_ssl not found in event_openssl library, or the library is not installed

after scratching my head for a while, i found out this was because i compiled libevent2 *before* installing openssl-devel. the error went away after a make clean && make && make install for libevent2.